Install MSI hangs for about three minutes - maybe Terminal Server issue

Topics: Server Deployment
Jun 11, 2010 at 7:44 AM

Hi,

When I install the generated MSI file using the batch file the wizard seems to hang for about three minutes "initializing". The machine I'm working on is quite fast, so this should not be a problem. This is part of the msiexec logile:

MSI (s) (D0:64) [09:22:30:883]: Note: 1: 2205 2:  3: Class
MSI (s) (D0:64) [09:22:30:883]: Note: 1: 2727 2:  
MSI (s) (D0:64) [09:22:30:883]: Note: 1: 2727 2:  
Action ended 09:22:30: InstallValidate. Return value 1.
MSI (s) (D0:64) [09:22:30:883]: Doing action: InstallInitialize
MSI (s) (D0:64) [09:22:30:883]: Note: 1: 2205 2:  3: ActionText
Action start 09:22:30: InstallInitialize.
MSI (s) (D0:64) [09:22:30:898]: Machine policy value 'AlwaysInstallElevated' is 0
MSI (s) (D0:64) [09:22:30:898]: User policy value 'AlwaysInstallElevated' is 0
MSI (s) (D0:64) [09:22:30:898]: BeginTransaction: Locking Server
MSI (s) (D0:64) [09:22:30:898]: Machine policy value 'LimitSystemRestoreCheckpointing' is 0
MSI (s) (D0:64) [09:22:30:898]: Note: 1: 1715 2: XXXXXX 2.1.0.0
MSI (s) (D0:64) [09:22:30:898]: Note: 1: 2205 2:  3: Error
MSI (s) (D0:64) [09:22:30:898]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1715
MSI (s) (D0:64) [09:22:30:898]: Calling SRSetRestorePoint API. dwRestorePtType: 0, dwEventType: 102, llSequenceNumber: 0, szDescription: "Installed XXXXXX 2.1.0.0".
MSI (s) (D0:64) [09:22:30:898]: The call to SRSetRestorePoint API failed. Returned status: 0. GetLastError() returned: 127
MSI (s) (D0:64) [09:22:30:898]: Server not locked: locking for product {D4ECC714-5C27-43AC-8AEE-C18E96F37AB7}
MSI (s) (D0:64) [09:22:31:086]: Opening Terminal Server registry propogation window.
Action ended 09:25:28: InstallInitialize. Return value 1.
MSI (s) (D0:64) [09:25:28:322]: Doing action: SetDEPLOYMENTDIR
MSI (s) (D0:64) [09:25:28:322]: Note: 1: 2205 2:  3: ActionText
Action start 09:25:28: SetDEPLOYMENTDIR.
MSI (s) (D0:64) [09:25:28:322]: PROPERTY CHANGE: Adding DEPLOYMENTDIR property. Its value is 'C:\KAV-IKT\BizTalk\Deployments\\Deployment'.
Action ended 09:25:28: SetDEPLOYMENTDIR. Return value 1.

You can see a 3 minute gap. I work on a terminal server. It seems to make no difference when I switch to the "Installmode" before installing via "change user /install".

Any Ideas? (I am not able to test on another machine yet).

Thank, Eljakim

 

Coordinator
Jun 11, 2010 at 1:58 PM

Is it showing a pop-up dialog over the install wizard at the time this occurs?  Have you tried mstsc /admin to connect to the server?  I'm curious what happens with the same MSI when you can test on another machine.

If there is some kind of issue related to Terminal Server, it is probably in WiX.  I asked about the pop-up dialog because every so often WiX shows a pop-up dialog about (I think) calculating disk space and it either never goes away or takes a very long time.

Thanks,
Tom

Jun 14, 2010 at 12:19 PM

Hi Tom,

the issue is a general MSI issue (exporting and installing the MSI from admin console has same effect). Installing on a terminal server session leads to some heavy registry access (some 500.000!!) mostly on Visual Studio 10 entries located in a specific Terminal Server subnode (a lot of people have similar problems with HP printer stuff):

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\RefHive\...]

I also tried using WiX 3.5 beta, but to no avail.

good news though: no problem of BTDF :D


Eljakim

Jun 18, 2010 at 8:51 AM

I just made my first installation on another (non-termal server) machine and it worked smoothly.

Thank you so much for this great project!

Coordinator
Jun 18, 2010 at 3:16 PM

Thanks for the update.  That's a relief!  :-)  I'm glad to hear that it wasn't an issue on my end, and thanks for the positive comments!

Thanks,
Tom