VS 2008 Add-ins - Empty Tools & Menus

Topics: Getting Started/Beginner, Visual Studio Integration
Jan 24, 2011 at 6:01 PM

Hi there

I upgraded today from 5.0.16 Beta to 5.0.25 RC, and now my Tools | Deployment Framework For BizTalk menu is there, but there are no sub-items under it.  As well the Toolbar items come up empty as well. 

I have tried uninstalling (the framework, as well as Add-in manager), reinstalling, rebooting without any luck.

I am running BizTalk 2009 so using Visual Studio 2008.

Any ideas?


Jan 24, 2011 at 6:28 PM

These are tough to solve.  After you uninstalled the Deployment Framework (hopefully with no Visual Studio instances running), did the add-in disappear from the Addin Manager, and did the menu and toolbar disappear?  The installer drops a .AddIn file in your user account's Documents\Visual Studio 2008\Addins folder; you can also ensure that it is gone after the uninstall.  Also after uninstalling, you can try running devenv.exe from a Command Prompt with the /setup switch and then the /ResetSkipPkgs switch.  If worst comes to worst, you could try a Repair on VS 2008.

Oftentimes when people have run into weird add-in issues then closing all VS instances, uninstalling BTDF, rebooting and reinstalling BTDF has taken care of it.  Sounds like you already tried that though.

Let me know if any of that helps.


Jan 24, 2011 at 7:33 PM

Thanks Tom, I got it to work with your suggestions.

Forgot to mentioned I am running Windows 7, so did not find the Addins in the folder you specified.  But I did find it at the following location:
Folder: C:\ProgramData\Microsoft\VisualStudio\9.0\Addins
FileName: DFBTVisualStudioAddIn.AddIn_

After uninstalling BTDF, this file still had an entry for BTDF Add in.  I removed this BTDF addin XML Element from the file. Reinstalled BTDF and everything was working again.
No reboot or "devenv.exe /resetskippkgs" required.

Thanks again for all your help


Jan 24, 2011 at 9:56 PM

Great!  I'm glad this one turned out to be a quick fix.


Nov 4, 2011 at 5:53 AM

I tried all of your suggestions. Nothing did it for me :-(

It worked fine for me until some windows patches were installed and machine reboot. I don't know, if this is the reason.

Other users on this machine do not have this problem.

VS 2008, BTDF 5.0.25 RC, Windows Server 2003 SP2

Any other suggestions? Thx!

Nov 10, 2011 at 5:46 AM

I am still confused with the problem.

New information: when I disable and enable the add-in via add-in-manager it says: "The parameter is incorrect (80070057)". So there is something wrong in the OnConnection(..)-Method of Connect.cs. Because I am the only user on this machine with this problem, I guess there's something wrong with the users environment-settings accessed by this method. (All users are admins.)

Nov 10, 2011 at 10:06 AM

Okay, I did not find the cause, but I solve the issue:

Just reset the Visual Studio Configuration (Tools -> Import & Export Settings Wizard).

Nov 10, 2011 at 6:43 PM

Thanks for the updates.  When you did the reset, do you know if you changed the configuration (General Development to C#, etc.)?  Maybe one of the default VS configurations doesn't agree with the add-in OnConnection() logic.