Deployment Fails With Missing XmlPreprocess Argument

Topics: Bindings File, Settings Management and SSO
Apr 29, 2011 at 4:15 AM

Hi, I am using the latest release of the BTDF, and have struck an issue where both local and server deployments fail with the following log file entry:

Clearing file attributes for 'PortBindings.xml'.
                "C:\Program Files\AAA\1.0\Deployment\Framework\DeployTools\xmlpreprocess.exe" /f /v /c /i:"C:\Program Files\AAA\1.0\Deployment\PortBindings.xml" /o:"C:\Program Files\AAA\1.0\Deployment\PortBindings.xml" /d:CurDir="C:\Program Files\AAA\1.0" /s:""
                XmlPreprocess v2.0.13.0
                Copyright (c) 2004-2010 Loren M Halvorson
                XML File Preprocessor

/s:: Argument expects a parameter

The top part of my project file looks like the following - is there anything I am doing wrong here ?

  <PropertyGroup>
    <Configuration Condition="'$(Configuration)' == ''">Debug</Configuration>
    <Platform Condition="'$(Platform)' == ''">x86</Platform>
    <SchemaVersion>1.0</SchemaVersion>
    <ProjectName>xxx</ProjectName>
    <ProjectVersion>1.0</ProjectVersion>
    <IncludePipelines>True</IncludePipelines>
    <IncludeComponents>True</IncludeComponents>
    <IncludePipelineComponents>True</IncludePipelineComponents>
    <IncludeEsbItineraries>True</IncludeEsbItineraries>
    <EnableAllReceiveLocationsOnDeploy>False</EnableAllReceiveLocationsOnDeploy>
    <IncludeMessagingBindings>true</IncludeMessagingBindings>
  </PropertyGroup>

The binding file is in the deployment folder where it should be??

 

regards

Grant

Coordinator
Apr 29, 2011 at 4:56 AM

Hello Grant,

Are you building under a project/solution configuration named either Debug or Release?  Did you generate the Deployment Framework project with the Add New Project wizard?  Do you have an EnvironmentSettings folder with an XML file under your deployment project folder?

Thanks,
Tom

Apr 29, 2011 at 5:29 AM

Hi Tom

Thanks for the quick reply - I have the solution configuration set to debug mode and used the wizard to create the file. Also the environment settings folder was present in the correct location.

I tried running a couple of the BizTalk 2009 sample projects that ship with BTDF and they failed with the same error.

After restarting my machine they now build ok - not sure what the issue was but seems ok now :-/

thanks

Grant