This project has moved and is read-only. For the latest updates, please go here.

BTDF error MSB4018: Microsoft.RuleEngine.RuleStoreConnectionException: Unable to connect to database BizTalkRuleEngineDb on server - Timeout error

Topics: Server Deployment
Mar 27, 2012 at 9:02 PM

Hi,

I have a BizTalk deployment framework built consisting of artifacts like orchestration, maps, schemas, business component and business rules (around 400). when i try to deploy the the application, i see all the artifacts are getting deployed without any errors including the rules, but when it tries to start the application it timesout, saying not able to connec t othe BizTalk Rule Engine.

here is the exact error

error MSB4018: The "ControlBizTalkApp" task failed unexpectedly.
C:\Program Files\MSBuild\DeploymentFrameworkForBizTalk\5.0\BizTalkDeploymentFramework.targets(1772,5): error MSB4018: Microsoft.RuleEngine.RuleStoreConnectionException: Unable to connect to database "BizTalkRuleEngineDb" on server "SERVERNAME" using connection "Initial Catalog=BizTalkRuleEngineDb;Data Source=SERVER;Integrated Security=SSPI;". ---> System.InvalidOperationException: Timeout expired.  The timeout period elapsed prior to obtaining a connection from the pool.  This may have occurred because all pooled connections were in use and max pool size was reached.

Any help/suggestion would be appriciated.

Thanks,

Mruthunjaya J

Mar 28, 2012 at 3:44 PM

Hi Mruthunjaya,

The normal process is that policies and vocabularies are published during rules deployment, but the policies are deployed during application start.  The start is executed through the BizTalk ExplorerOM object model.  It sounds like due to the volume of policies that you have, it's timing out on a database connection.

Here are two things to try:

  1. Add a property ExplicitlyDeployRulePoliciesOnDeploy set to true in your .btdfproj.  That will accelerate the policies deployment to the same point in time that they are published.
  2. If that doesn't help, add a property StartApplicationOnDeploy set to false in your .btdfproj.  This will completely skip starting the BizTalk app.  Once the deployment completes, try starting the app through BizTalk Admin and see what happens.

Thanks,
Tom

 

 

 

 

 

Mar 28, 2012 at 6:15 PM

Hi Tom,

Thanks for the response, I always had the option 2 to proceed further, but option 1 is solving the problem. I tried setting the value ExplicitlyDeployRulePoliciesOnDeploy to true and it deployed successfully. Appreciate your help.

Thanks,

Mruthunjaya J