XmlPreProcess not replacing the binding file values

Topics: Bindings File, Settings Management and SSO, General Questions, Server Deployment
Apr 4, 2012 at 10:23 AM

Hi

I have a PortBindingsMaster.xml which is normalized using elementtunnel.exe and I have replaced the below code for xml pre processing based on the Environment specific files such as Exported_DevSettings.xml.

   <!-- ifdef ${_xml_preprocess}-->
  <!-- <Address>$(FileSendLocation)\%MessageID%.xml</Address> -->
  <!-- else-->
  <Address>C:\BizTalk\Out\%MessageID%.xml</Address>
  <!-- endif-->

In the SettingsFileGenerator.xml file I have a variable defined as FileSendLocation .

Also in the btdfproj file I have (tried) the following properties set as below

    <IncludeMessagingBindings>true</IncludeMessagingBindings> 
    <ApplyXmlEscape>true</ApplyXmlEscape>
    <UsingMasterBindings>true</UsingMasterBindings>
    <RequireXmlPreprocessDirectives>true</RequireXmlPreprocessDirectives> 

I have generated the MSI and started doing the deployment.Everything going fine except 1 error saying  An invalid value for property "DestinationFolder".

I had a look into the deployment folder where the PortBindings.xml generated ,which has the following

<PrimaryTransport>
        <Address>$(FileSendLocation)\%MessageID%.xml</Address>

So, it suggests me that the XML proprocessing is not replacing the variable with the value from the  Exported_DevSettings.xml, hence the error is thrown.

Could anyone suggest if I am missing anything here ,Please.

Also, what are the other options for me to specify the binding files only during the deployment (by <IncludeMessagingBindings>false</IncludeMessagingBindings> 
        <UsingMasterBindings>false</UsingMasterBindings>
)

The idea is not to break the deployment process due to binding issues or seperating the deployment process from the binding

Thanks

 

 

Apr 4, 2012 at 11:05 AM

Oops..My bad

I had $(FileSendLocation) instead of ${FileSendLocation} to specify the variables inside the bidning file .

Its wokring fine now.Thanks.