Deployment on non last Biztalk server - why is it stopping Biztalk server

Topics: General Questions, Server Deployment
Jul 10, 2014 at 3:24 PM
Edited Jul 10, 2014 at 6:20 PM
When we do deployment on non last server ( just GAC dlls) , it is stopping BizTalk in the step Target ServerUndeploy. Why is it doing this? It is now happening for other applications, but only for one of the applications.

__Log Results:

Target Undeploy:
Target ServerUndeploy:
    Target SetWinVer:
        Running on Windows V61
        Detected IIS 7
        Detected 64-bit OS
    Target GetSoftwarePaths:
        Using .NET Framework Install Path 'C:\Windows\Microsoft.NET\Framework\v2.0.50727'.
        Using BizTalk Install Path 'C:\Program Files (x86)\Microsoft BizTalk Server 2010\'.
        Using Deployment Framework Install Path 'C:\Program Files (x86)\Mlits.BTS.MedicalBill for BizTalk\1.0\Deployment\'.
        Using Deployment Framework Tools Path 'C:\Program Files (x86)\Mlits.BTS.MedicalBill for BizTalk\1.0\Deployment\Framework\DeployTools'.
    Target ExportSettings:
        Skipping settings file export because file at SettingsSpreadsheetPath does not exist: C:\Program Files (x86)\Mlits.BTS.MedicalBill for BizTalk\1.0\Deployment\EnvironmentSettings\SettingsFileGenerator.xml
    Target InitSettingsFilePath:
        Invalid settings file path (OK on server undeploy).
    Target StopBizTalk:
        iisreset.exe /noforce /restart /timeout:60            
        Attempting stop...            
        Internet services successfully stopped            
        Attempting start...            
        Internet services successfully restarted            
        Target StopAllBizTalkHosts:

We are running this using command line in .bat files.

Steps in batch file:

1) Undeploy with DeployBizTalkMgmtDB = false
2) Unistall application using ProductId
3) Install application using ProductId
4) Deploy with DeployBizTalkMgmtDB = false
Coordinator
Jul 10, 2014 at 3:58 PM
Do you have DeployPDBsToGac set to True anywhere? If so, remove it or set it to False.
Jul 10, 2014 at 6:19 PM
Thanks Tom!