TestEcho fails in DeploymentTest on Advanced Sample (64-bit Windows 2008 R1)

Topics: General Questions
Oct 6, 2009 at 12:31 PM

Hi there

Please note: this is a possible solution, not a question. But comments are very welcome anyway.

Being new to DFB I thought I give the included BizTalkSample a spin on by 64 bit Windows Server 2008 R1.

However, after the deployment, the test TestEcho in DeploymentTest failed with a HTTP error 500. Detailed Error Information:

Module

IsapiModule

Notification

ExecuteRequestHandler

Handler

ISAPI-dll

Error Code

0x800700c1

Requested URL

http://[MyServer]:80/BizTalkSampleVDir/btshttpreceive.dll

Physical Path

C:\Program Files (x86)\Deployment Framework for BizTalk\5.0\BizTalkSample_BT2009\BizTalkSampleVDir\btshttpreceive.dll

 

After a bit of Googling and trial and error I found the following:

 “If your operating system is the x64 edition of Microsoft Windows Server 2003 or Windows Server 2008, the 64-bit version of the HTTP receive adapter is installed to the <drive>\Program Files (x86)\Microsoft BizTalk Server 2009\HttpReceive64 directory of your BizTalk Server by default. To run the 64-bit version of the HTTP receive adapter in 64-bit native mode you must execute the following script from a command line:

 

cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 0

 

C:\WINDOWS\Microsoft.NET\Framework64\vX.X.XXXXX>aspnet_regiis.exe –I

from  http://msdn.microsoft.com/en-us/library/aa559072(BTS.10).aspx

This can also be accomplished using the GUI of the IIS Manager. You’ll have to set Enable 32-Bit Applications to False, under advanced setting of the application pool running BizTalkSampleVDir.

 

Best regards,

Michael Brandt Lassen

3F, Denmark