Regarding deployment

Jan 7, 2010 at 6:36 AM

Hi i'm a trainee learing biztalk 2004. When i'm installing the assemblies through the deployment wizard i'm getting error and orchestrations not found in the Biztalk adminstration console. I'm working on the first application present in the Biztalkserver 2004 unleashed..

 

Thanks in advance.. Pls help me

 

Santhosh

Jan 7, 2010 at 10:35 PM

Did you copy in a .btdfproj file and customize it for your project? Did you line up your project names to match the recommendations? 

In my opinion, there is a significant amount of configuration to get the first deploy to work.   You also have to export your binding file to the appropriate place. 

What is the first (or all) errors you are getting in your output windows?

I've only used BTDF with 2006 and later.  The developers may have to comment as to whether it works on 2004.   You might have to have NANT installed, did you do that?

Neal

Coordinator
Jan 7, 2010 at 10:43 PM

Version 4.0 was the last release to support BizTalk 2004.

Per your comment on "line up your project names," the Deployment Framework has always supported single-assembly deployment, if desired.  If you have one project that contains maps, schemas and orchestrations, you can just list the file name without .dll in the <Schemas> element and disable IncludeTransforms, IncludeOrchestrations, etc.

Tom

Jan 7, 2010 at 10:50 PM
Edited Jan 7, 2010 at 10:52 PM

Tom,

I know there are less and less people on 2004, but might be nice to make it obvious on the 5.0 download page:

It says:

- Now includes support for BizTalk Server 2006, 2006 R2 and 2009

One could read that as though support has been added to what used to be supported in prior release, 2004 to also include ....

Under that, would be nice to have a bullet:  - Not compatible with BT2004, use Version 4.

(Or even better a release support matrix of your releases to BT releases.)

Neal