Unable to GAC Assembly

Topics: Getting Started/Beginner
Nov 17, 2010 at 3:06 PM

I am a newbie to deployment framework. I tried the sample project couple of times and now trying to implement on a sample project.

 Created my sample project and then manually deployed


 Created sub folder called DynamicMaps.Deployment in the solution folder.

 Copied everything from C:\Program Files\Deployment Framework for BizTalk\5.0\Samples\BizTalk2009\Advanced

 From BizTalk Admin Console Exported Portbindings onto  PortBindingsMaster.Xml 


 Updated DynamicMaps.Deployment.BTDFProj file to include  Orchestrations,Transforms,Schemas,Uitlity


 In the next line added the following to include DynamicMaps.Uitlity
 <Components Condition="'$(Components)'==''">$(ProjectName).Utility</Components>


 The problem I have is DynamicMaps.Uitlity.Dll assembly is not getting GAC'ed? On deploying the solution I would like this assebly to be gaced and ungaced
 un undeploying the solution.

 "Copy Local" is set to true in all the project references
 Could someone help me please?



Nov 17, 2010 at 4:18 PM

I'm not sure what Deployment Framework version you are using, but the syntax for <Components> was changed a long time ago.  I assume that you are on BizTalk 2006 or newer?  Please update to the current release here, review the included Developer's Guide and use the Add New Project wizard to create the deployment project for your sample solution.  I don't think you'll have any trouble after that, but if you do please post again here.


Nov 17, 2010 at 5:01 PM
Edited Nov 17, 2010 at 5:21 PM

Thanks for your response.

I must mention few things here.

I am using BizTalk Server 2009 Standard edition / Visual Studio 2008 / BTDF 5 beta verion.

1. This morning I noitced BTDF version 5.0

  Downloaded the new version

 Uninstalled the old version (beta version to Framework 5.0)

 Installed the new version and tried my project but the result was the same - the assembly was not gaced 

2. And then closed the Visual Studio 2008 reopened it -  This time deployment framework options were not present in Tool menu.

 Now I have gone back to the beta version to Framework 5.0 and the problem I mentioned above  occurs in the beta version.

3. One thing I ahven't tried is haven't created DynamicMaps.Deployment.BTDFProj using the project wizard.

If you think the Sytax for <Componets> have changed lon time ago,please could you advise me what should I do to invlude the Utility.Dll?





Nov 17, 2010 at 5:19 PM

Hi Shiva,

In VS 2008, please check the Add-in Manager and see if the Deployment Framework for BizTalk add-in is checked.

As for <Components>, where did you get the syntax that you are using?  You should have <ItemGroup><Components Include="$(ProjectName).Utility.dll"><LocationPath>..\$(ProjectName).Utility\$(Configuration)\bin</LocationPath></Components></ItemGroup> as you'll see in the Developer's Guide and created by the Add New Project wizard.