This project has moved and is read-only. For the latest updates, please go here.

BTSTask AddApp fails on server with separate SQL messagebox

Topics: Server Deployment
Feb 10, 2012 at 1:15 AM

I have an odd issue with BTSTask AddApp on some servers at a client site. When AddApp is called it always fails with:

Error: Invalid database name "NAMEDINSTANCE_BizTalkMgmtDb".
Parameter name: Database

BizTalk and SQL are installed on separate machines, and the SQL box hosts several BizTalk server databases (for testing). The BizTalk databases are prefixed with the environment name.

I have even tried passing in the -server & -database parameters and it still doesn't work, adding applications in the admin tool does work fine.


Has anyone seen this issue before?

Feb 13, 2012 at 5:12 AM

You didn't say what version of BizTalk you're using, but you might try installing the latest Cumulative Update for BizTalk if you haven't already, and possibly the latest service pack version of the SQL Server client tools for your version of SQL Server.

Since this is a BizTalk product-related issue, you'll probably have a better response at the MSDN BizTalk Forums.


Feb 13, 2012 at 7:32 AM

I  have followed up on the BTS forums,

I was just hedging my bets in case someone had come across something similar with BTDF.

I have come to the conclusion that BTSTask will not allow renamed BizTalk databases, this is the first time in 10 years I have seen someone place multiple BizTalk installations on a single SQL box so I imagine this is pretty rare.

My only hope is to convince the client to return BizTalk to dedicate SQL instances.