copying of pipelinecomponentdll failed

Topics: General Questions
Apr 10, 2012 at 12:10 PM

i am deploying the my solution using deployment framework in my local system (not through MSI but using deploy option in VS)

I am getting the following error

Its telling the system cannot find the assembly.

I rechecked and i can see the pipelinecomponent dll in release folder.

Can any one tell me where i am going wrong..??

Any suggestions are greatly appreciated.

DeployPipelineComponents:

Copying file from "..\ACE.Exigen.BizTalk.Common.PipelineComponent\bin\Release\ACE.Exigen.BizTalk.Common.PipelineComponent.dll" to "C:\Program Files (x86)\Microsoft BizTalk Server 2010\Pipeline Components\ACE.Exigen.BizTalk.Common.PipelineComponent.dll".

copy /y "..\ACE.Exigen.BizTalk.Common.PipelineComponent\bin\Release\ACE.Exigen.BizTalk.Common.PipelineComponent.dll" "C:\Program Files (x86)\Microsoft BizTalk Server 2010\Pipeline Components\ACE.Exigen.BizTalk.Common.PipelineComponent.dll"

"C:\Program Files (x86)\Deployment Framework for BizTalk\5.0\Framework\DeployTools\gacutil.exe" /i "..\ACE.Exigen.BizTalk.Common.PipelineComponent\bin\Release\ACE.Exigen.BizTalk.Common.PipelineComponent.dll"

Microsoft (R) .NET Global Assembly Cache Utility. Version 4.0.30319.1

Copyright (c) Microsoft Corporation. All rights reserved.

 

Failure adding assembly to the cache: The system cannot find the file specified.

 

C:\Program Files (x86)\MSBuild\DeploymentFrameworkForBizTalk\5.0\BizTalkDeploymentFramework.targets(1363,5): error MSB3073: The command ""C:\Program Files (x86)\Deployment Framework for BizTalk\5.0\Framework\DeployTools\gacutil.exe" /i "..\ACE.Exigen.BizTalk.Common.PipelineComponent\bin\Release\ACE.Exigen.BizTalk.Common.PipelineComponent.dll"" exited with code 1. [D:\SANDEEP\ACE.Exigen.CommonRoutingSvcChange - 06April2012\ACE.Exigen.BizTalk\CommonFramework\ACE.Exigen.BizTalk.Common\ACE.Exigen.BizTalk.Common.Deployment\ACE.Exigen.BizTalk.Common.Deployment.btdfproj]

Done Building Project "D:\SANDEEP\ACE.Exigen.CommonRoutingSvcChange - 06April2012\ACE.Exigen.BizTalk\CommonFramework\ACE.Exigen.BizTalk.Common\ACE.Exigen.BizTalk.Common.Deployment\ACE.Exigen.BizTalk.Common.Deployment.btdfproj" (Deploy target(s)) -- FAILED.

Build FAILED.

"D:\SANDEEP\ACE.Exigen.CommonRoutingSvcChange - 06April2012\ACE.Exigen.BizTalk\CommonFramework\ACE.Exigen.BizTalk.Common\ACE.Exigen.BizTalk.Common.Deployment\ACE.Exigen.BizTalk.Common.Deployment.btdfproj" (Deploy target) (1) ->

(DeployPipelineComponents target) ->

C:\Program Files (x86)\MSBuild\DeploymentFrameworkForBizTalk\5.0\BizTalkDeploymentFramework.targets(1363,5): error MSB3073: The command ""C:\Program Files (x86)\Deployment Framework for BizTalk\5.0\Framework\DeployTools\gacutil.exe" /i "..\ACE.Exigen.BizTalk.Common.PipelineComponent\bin\Release\ACE.Exigen.BizTalk.Common.PipelineComponent.dll"" exited with code 1. [D:\SANDEEP\ACE.Exigen.CommonRoutingSvcChange - 06April2012\ACE.Exigen.BizTalk\CommonFramework\ACE.Exigen.BizTalk.Common\ACE.Exigen.BizTalk.Common.Deployment\ACE.Exigen.BizTalk.Common.Deployment.btdfproj]

0 Warning(s)

1 Error(s)

 

 

Coordinator
Apr 10, 2012 at 6:18 PM

Was the latest DLL successfully copied to C:\Program Files (x86)\Microsoft BizTalk Server 2010\Pipeline Components\ACE.Exigen.BizTalk.Common.PipelineComponent.dll from the first step?

You can also take the command shown above for gacutil and run it from a Command Prompt.  Just cd to your deployment project folder, then run: "C:\Program Files (x86)\Deployment Framework for BizTalk\5.0\Framework\DeployTools\gacutil.exe" /i "..\ACE.Exigen.BizTalk.Common.PipelineComponent\bin\Release\ACE.Exigen.BizTalk.Common.PipelineComponent.dll"

You should get the same error, but let me know.

Thanks,
Tom