Add Virtual Directory as a BTS resource failing - bug?

Topics: IIS and Web Services, Server Deployment
Jul 27, 2012 at 4:26 PM

Hi,

In BTDF there is a property "IncludeCompsAndVDirsAsResources" to add VDir as a resource in "DeployVDirs" target but the condition doesn't include a check to do this only on a Primary Server and because of this , in multi server environment,if we deploy on secondary box first it will fail because BT App is not created and if we deploy after the primary then it complains this resource is already there....possible solutions,

1. Add a check to do this only on Primary server. Change Condition="'$(IncludeCompsAndVDirsAsResources)' == 'true'" to Condition="'$(IncludeCompsAndVDirsAsResources)' == 'true' and '$(DeployBizTalkMgmtDB)' == 'true'"

2. Change -Source:"http://localhost/%(VDirList.Vdir)" to use hostname...

Has anyone experience this issue before? I haven't look this in a greagter detail so I might have got this wrong so please let me know if that's the case.

 

Regards,

Manan 

Coordinator
Jul 30, 2012 at 3:31 AM

Hi Manan,

Thanks for the report.  The first question I always ask when someone mentions the IncludeCompsAndVDirsAsResources property is: why do you need to turn it on?

It really has no place in a Deployment Framework for BizTalk solution (it probably should have been removed altogether), because the Framework completely takes care of deploying and undeploying virtual directories.  Someone who is using the Framework should never use the built-in MSI export/import that BizTalk provides, and that's what this property relates to.  Hopefully you are using the Deployment Framework to generate an MSI and not BizTalk's tools.

Thanks,
Tom

Jul 30, 2012 at 8:33 AM

Hi Tom,

 

Thanks for the response.

I agree with you and I personally never used this property before but I'm at a customer site where this is enabled. I just wanted to highlight this behaviour and ,as you suggested, I might turn off this flag on this occasion as well.

Regads,

Manan