Getting Error when ToolsVersion value is set to 4.0

Topics: Bindings File, Settings Management and SSO, Getting Started/Beginner, Server Deployment
Dec 27, 2013 at 8:52 PM
We are receiving the following error when ToolsVersion value is set to 4.0. It works when I remove ToolsVersion value ( default is 2.0) on my computer. Can someone please help me understand what is happening behind?

C:\Program Files (x86)\MSBuild\DeploymentFrameworkForBizTalk\5.0\BizTalkDeploymentFramework.targets(1744,5): error MSB4062: The "Microsoft.Sdc.Tasks.BizTalk2006.Application.Delete" task could not be loaded from the assembly C:\Program Files (x86)\MSBuild\DeploymentFrameworkForBizTalk\5.0\Microsoft.Sdc.Tasks.BizTalk.dll. Could not load file or assembly 'file:///C:\Program Files (x86)\MSBuild\DeploymentFrameworkForBizTalk\5.0\Microsoft.Sdc.Tasks.BizTalk.dll' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.

Thanks!
Pavan
Coordinator
Dec 28, 2013 at 1:18 PM
Hi Pavan,

It sounds like you are using an old version prior to the 5.0 release. If you're using a build server, make sure that you have the same version of the Deployment Framework installed there. What version do you have installed?

Thanks,
Tom