Randy Paulo PowerShell script error on deploy

Topics: Server Deployment
Sep 12, 2014 at 7:29 PM
Hi,

I’m trying to deploy a BizTalk application by powershell script but Im getting some problems. This application has BAM definition and it seems that the observation model file cannot be found.


Here is my command:

Executing MSBuild from: C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe

ArgList: /p:DeployBizTalkMgmtDB=True;Configuration=Server;SkipUndeploy=True /l:FileLogger,Microsoft.Build.Engine;logfil
e="D:\Program Files\Transat\TORadixx.PNRExport\DeployResults\DeployResults.txt" "D:\Program Files\Transat\TORadixx.PNREx
port\Deployment\Deployment.btdfproj"
Exit Code: 1

This is the error:
D:\Program Files\Transat\TORadixx.PNRExport\Deployment\Framework\BizTalkDeploymentFramework.WiXSetup.targets(180,5): error MSB3021: Unable to copy file "..\PNRExport.BAM\ObservationModel\TR_PNRExport_ObservationModel.xml" to "obj\Server\redist\BAM\TR_PNRExport_ObservationModel.xml". Could not find a part of the path '..\PNRExport.BAM\ObservationModel\TR_PNRExport_ObservationModel.xml'.


I found the missed file in D:\Program Files\Transat\TORadixx.PNRExport\BAM instead of in ..\PNRExport.BAM\ObservationModel\TR_PNRExport_ObservationModel.xml

On project
<!--BAM observation model to update--> <ItemGroup>
<BamDefinitions Include="TR_PNRExport_ObservationModel.xls">
  <LocationPath>..\PNRExport.BAM\ObservationModel</LocationPath>
</BamDefinitions>
</ItemGroup>


I doing something wrong ?

Thanks

Javier
Coordinator
Sep 15, 2014 at 4:32 AM
Hi Javier,

I assume you are using Randy Paulo's PowerShell script or something similar. You are missing /t:Deploy.

Thanks,
Tom
Sep 15, 2014 at 12:01 PM
Tom,

Yes, my script is based on Randy's script. And you was right, It missed the /t:deploy parameter. Now, It woks just great ! Thanks Tom