Deployment Framework Toolbar in Visual Studio 2008

Jan 28, 2010 at 10:05 PM

Hi.  I'm not able to use the Deployment Framework toolbar in VS 2008 and wanted to see if anyone had suggestions on how to fix.  I just upgraded to BizTalk 2009 and then installed the V5_0_10 version of the deployment framework.  When I open Visual Studio the DF toolbar is not loaded but I can open the Add-In Manager and I see the "Deployment Framework for BizTalk 5.0" add-in checked.  I tried unchecking and re-checking the option, but after clicking ok from Add-in Manager I get the following error:

 

The Add-in "Deployment Framework for BizTalk 5.0' failed to load or caused an exception.  Would you like to remove the Add-in?  If you choose yes, the file it was loaded from, 'C:\Documents and Settings\All Users\Application Data\Microsoft\VisualStudio\9.0\\AddIns\DFBTVisualStudioAddIn.AddIn', will be renamed.

Error Message: Invalid pointer

Error Number: 80004003

 

Any ideas?

Coordinator
Jan 29, 2010 at 4:52 AM

I've never heard of trouble loading the add-in before.  You could try going to VS Command Prompt and running "devenv /setup", which kind of re-configures all VS add-in packages.  devenv /? will give you some other options that you could try out.

Do you have a solution open when you are trying this?  Any other add-ins installed?

Thanks,
Tom

Feb 1, 2010 at 2:18 PM

Something was wrong with my Visual Studio 2008 installation, so after repairing the install the DF toolbar works fine now.

Thanks.